Objectives
To understand basic concepts of surface modeling and solid modeling.
To understand basic concepts of 3D parallel-line and perspective viewing.
To learn basic AutoCAD commands for creating and viewing 2-1/2D and 3D models. (These topics are presented in considerably more detail in Architecture 521, CAD Fundamentals II.)

Exercise:

1. Open your floor plan file from the Layers assignment (Assignment 5). While this is a 2D drawing, AutoCAD technically represents all points in terms of XYZ coordinates. So technically, it’s a 3D drawing, with Z-coordinates of 0.00 for all the points.

   Note that for this assignment, your walls should have “endcaps.” When a wall is represented as two parallel lines, an endcap is a short line segment spanning from one side of the wall to another at the end of the wall. The image below shows examples of walls with and without endcaps:

   ![Walls with and without endcaps](image)

   Walls with endcaps                      Walls without endcaps

   If your floor plan has any walls without endcaps, you should add endcaps now.

2. Experiment with ways to specify parallel-line 3D views.

   Select “View->3D Views->Viewpoint Presets…” from the pull-down menus. This brings up a dialog box that you can use to specify a direction from which to view your drawing/model:
Specify a viewing angle by clicking once on the left diagram, and once on the right one. The left diagram is used for specifying whether you want to view the drawing/model from the south (270°), the northeast (45°), etc. The right diagram is used for specifying how far up in the air (or how far underground) you want to view the drawing/model from. The “0°” indicates ground level; a view from 0° will be an “elevation,” e.g. a “front,” “side,” or “back” view, depending on the angle specified in the left half of the diagram. Angles above the “0°” in the right part of the diagram indicate views from the air, looking down on your drawing/model. Usually, angles below the “0°” in the diagram are not used, since they indicate views from below the object (i.e., from underground). Click “OK” after specifying both components of the viewing angle.

Note that the objects in the drawing/model are not being moved or rotated in space when you view the drawing/model in this manner. In effect, you are moving, not the drawing entities. The X-, Y-, and Z-coordinates of all your points remain the same.

If necessary, practice using the command to obtain the views you want. Once you understand how this command works, type “PLAN” (or go to “View->3D Views->Plan View->World UCS”) to return to a plan view.

Then experiment with the “ORBIT” command (“Views->3D Orbit”). This command separates the screen into different regions:

Clicking and dragging in the different regions allows you to rotate the drawing/model. Again, however, the coordinates of objects in the drawing/model are not changing; you are changing your viewing position. Doing this makes the object (and all of space, as indicated by the coordinate triad in the lower left) appear to rotate.

Clicking and dragging outside of the big circle rotates the objects about an axis coming out of the screen. (Clicking and dragging outside of the big circle changes what is called the “twist” angle, in computer graphics terms.) Clicking and dragging on one of the four little circles will rotate the objects about an axis up-and-down or left-and-right. Clicking and dragging within the big circle will spin the objects about a combination of the latter two axes.

Note that you can still ZOOM with the mouse wheel (if you have one) in the middle of the ORBIT command.

Once you have mastered the ORBIT command, go to a 3D view that you are comfortable with. Turn off all of your layers except for the layer for the one showing walls.

3. **Extrude your walls into a 2-1/2D surface model.** To do this, select all of your walls, but not stairs, break lines, counters, or other objects. Double-click one of the selected entities, to bring up a “Properties” palette.
Under the “General” parameters, change the “Thickness” to 8’. This gives each line, arc, circle, etc. a vertical thickness. For instance, LINEs take the appearance of vertical planes (although AutoCAD still treats them as LINE entities). You can use a Thickness value of more or less than 8’ if you wish, but 8’ is the typical floor-to-ceiling height for residential construction in the US.

4. Remove hidden lines from a 3D view of your building. Use ORBIT or “View->3D Views->Viewpoint Presets…” to get a view of the surface model.

Once you have done this, type “HIDE”. This removes all edges that are hidden (occluded) by a surface in front of them.

Note that your walls are “hollow”. This is because you have only generated vertical surfaces. The walls are not solids, and furthermore, they don’t have any horizontal planes “capping” the tops (or bottoms).

5. Experiment with other uses of the ORBIT command. Type “ORBIT”, or choose the command from the menus.

Once you are in the ORBIT command, right-click the mouse in the graphics window. This will bring up a pop-up menu with various useful commands and settings. This pop-up menu will appear any time you right-click in the middle of the ORBIT, ZOOM, or PAN commands. First try “Shading Modes->Hidden” to see the alternate way of triggering hidden-line removal.

Right-click again and go to “Visual Aids->Grid”, if a grid at floor level is not showing already.

Right-click again, and go to “Projection->Perspective”, and note how objects that are farther away now appear smaller than objects that are closer.

In parallel-line projections, like plans, elevations, or the 3D views you saw previously, lines that are parallel in the model remain parallel in the image. In perspective images, however, lines that are parallel in the model usually converge towards vanishing points. Such views can not be measured with a scale, but they are closer to the sort of view that a human sees when looking at a three-dimensional object.

After looking at the perspective, return to a parallel-line view by checking “Projection->Parallel” in the pop-up menu. AutoCAD does not allow you to do much editing in perspective views.
Next, go to “More->Orbit Maintains Z”. This changes the behavior of the ORBIT command somewhat. It makes it easier to keep the Z-axis pointed in the desired direction on the screen (usually upwards), while still looking at the model from above the ground plane. Try rotating the model with this option checked, and note the difference from the previous behavior of ORBIT. If necessary, turn “Orbit Maintains Z” off again, practice rotating the model using ORBIT, then turn “Orbit Maintains Z” on again, and practice rotating the model using ORBIT some more. Practice both modes, until you get used to them.

Lastly, in the pop-up menu, check “More->Continuous Orbit”. Then click on the screen, and keep the mouse button pressed down. Move the mouse very slightly, and release the mouse button. This should send the model “spinning”. The less you move the mouse with the button held down, the slower the model will spin. Practice until you are satisfied with your skill. Press “Esc” when you are done.

6. **Set the default THICKNESS for new entities to 3’ (or some other number that you think would be good for the distance from the floor to the bottom of a window).** Type “THICKNESS” at the command prompt, or choose “Format->Thickness” from the menus.

   Provide a value of 3’ (or some other value you prefer) at the prompt:

   Command: thickness

   Enter new value for THICKNESS <0'-0”>: 3'

7. **Create LINEs to represent the wall surfaces below window openings in your living room (or some other room, if you prefer).** This tutorial will refer to this room as your “chosen room” from this point on.

   In order to create the wall surfaces, you first must set your object snapping mode to “Endpoint”, and turn on object snapping.

   Use the ORBIT command to get a view where you can see the walls of your chosen room clearly. While in the ORBIT command, right-click to use the pop-up menu (“Shading Modes->Wireframe”) to turn off hidden line removal for now.

   Fill in the walls under your windows by drawing LINEs from one end of the opening to the other. Make sure that you object snap to the bottom corners of the walls on each side of the window opening:
Make sure that you draw both lines (i.e., vertical planes) under each window: the one on the interior side and the one on the exterior side, as shown.

Draw lines like this below each window in your chosen room.

8. **Create LINEs to represent the wall surfaces above door and window openings in your chosen room.**

   Set your THICKNESS to -1’4” (*negative* 1’4”). This is the distance from the bottom of an 8’ ceiling to the top of a 6’8” door or window. This is a standard distance for typical ceilings and typical doors/windows, but you can use a different value instead of -1’4”, if you wish.

   Draw lines above each door and window in your chosen room, object snapping to the tops of the walls on each side of the opening. (Click points directly above the points you clicked in step 8, plus points above any doors you have.)

   Since you specified a negative thickness for the lines, the lines are extruded downwards, to the tops of the doors and windows, instead of upwards.

   This is the last of the required 2-1/2D modeling.

9. **Display the “Surfaces” Toolbar.** This can be done by going to “View->Toolbars” in the pull-down menus.

10. **Use 3DFACEs to draw window sills in your chosen room.** 3DFACEs are the basic entity used in 3D surface modeling in AutoCAD; they represent a quadrilateral (or a triangle, if you put 2 of the corners in the same place) in space. Other 3D surface modeling commands just create groups of 3DFACEs. 3DFACE is the second command on the “Surfaces” toolbar.

   Create a single 3DFACE at the bottom side of each window opening in your chosen room:
If your windows do not already have vertical planes (endcaps) on the sides of the window openings, like the model in the image above has, then you should add them now using LINEs or 3DFACEs.

Note: Even when you remove hidden lines using the HIDE command or “Hidden” Shading Mode, you will still see the “seams” extending vertically from the corners of your window, as seen in the above image. These are visible because they are the edges of surfaces. They are part of the price you pay for using the “quick and dirty” 2-1/2D surface modeling specified in this tutorial.

11. Create a pyramid that sits on the floor of your chosen room. It does not have to be a regular pyramid with a square base. Choose the pyramid icon on the Surfaces toolbar.

The command will first ask you for 4 points for the base of the pyramid. Click four points on the floor of your chosen room. Note that you’ll be drawing at least 5 more objects in this room, so don’t fill up the entire room with the pyramid.

AutoCAD will prompt you for a fifth point. Before you enter the fifth point, type “.xy” (note the period in “.xy”). This will cause AutoCAD to read only the X- and Y-coordinates of the point you click, and prompt you for the Z-coordinate separately:

```
Command: _ai_pyramid
Initializing... 3D Objects loaded.
Specify first corner point for base of pyramid: <click a point>
Specify second corner point for base of pyramid: <click a point>
Specify third corner point for base of pyramid: <click a point>
Specify fourth corner point for base of pyramid or [Tetrahedron]: <click a point>
Specify apex point of pyramid or [Ridge/Top]: .xy of <click a fifth point on the floor>
```

For the fifth point, click a point of the floor; the actual apex of the pyramid will be located directly above this point by a distance that you indicate. Once you click the point on the floor, AutoCAD will respond:

```
(need Z):
Type a value for the height that you want your pyramid to be.
```

12. Create a cube (or other hexahedron) and a cylinder that also sit on the floor of your chosen room, and overlap your pyramid slightly. These can be created using other commands from the “Surfaces” toolbar. Note that for surface modeling, AutoCAD uses the same command for cones, truncated cones, and cylinders.
You should be able to figure out the interaction on your own, but note that you will find it easiest if you type the radii for the cylinder, rather than clicking on-screen for them.


14. *Create a solid cylinder on the floor of your chosen room.* Use the cylinder command from the “Solids” toolbar.

   You can click when asked for a center point for the cylinder, but type a value for the radius. You will also probably want to enter the height by typing a value.

15. *Create a solid cone that sits neatly on top of the cylinder from the previous step.* The base of the cone should have the same radius as the cylinder, and should be centered on the top surface of the cylinder. (Use object snapping when you specify the center of the base, to help you do this.)

16. *Create a solid box that intersects your cone and cylinder.* An example is shown below. Your box, cone, and cylinder can look different, as long as the cone sits on the top of the cylinder, neatly covering it, and the box intersects both of them. Your box needs to intersect both the cone and the cylinder, so that the instructors will be able to evaluate whether or not you have done your set operations correctly in the next few steps.
17. Display the Solids Editing toolbar.

18. Union your cone and cylinder together. Use the first command on the solids editing toolbar, and select both the cone and the cylinder. This merges them together into a single form.

Unioning is an example of a Boolean set operation. The other Boolean operations are subtraction (or difference) and intersection. These are the second and third icons on the Solids Editing toolbar. All of these operations involve not just the surfaces of objects, but also their interiors. They do not work on surface models. In fact, these operators are among the defining features of solid (as opposed to surface) modeling. A solid model is something that you can perform Boolean operations on.

19. Subtract your cube from the form you generated in the previous step. Use the second command on the Solids Editing toolbar for this.
20. *Embellishment and extra work.* To embellish your drawing, experiment with other surface modeling and solid modeling commands. Try creating tabulated, ruled, or edged surfaces. Try creating extruded and revolved solids. Experiment with using the MOVE command to move objects up or down in the Z direction. Try using the ROTATE3D command (“Modify->3D Operation->Rotate 3D”) to rotate objects about some axis of rotation other than the Z-axis. Try setting up a UCS in some non-horizontal plane (e.g., a wall), and drawing something 2-1/2D (this can be a quick-and-easy, though somewhat crude, way of drawing stairs). The more different and difficult commands you try, the better.

You can try to create furnishings for your building, using solids modeling. Try creating a chair, table, lamp, and/or other pieces of furniture. You can also use 3DFACEs as in step 10 to add window sills to windows and top jambs to doors and windows throughout your model. The greater the control of modeling commands you demonstrate, the better.

21. *Plot a parallel-line projection of your file.* Type “ORBIT” or choose “View->3D Views->Viewpoint Presets...” from the menus, and use ZOOM, PAN, etc. to specify a parallel-line view that shows your entire house, but also shows most of the objects in your chosen room. The view should show your house from above, looking down into it. Be sure not to show the house from below, looking up into the rooms.

Make sure that in either this plot or the next one, it is possible to see the sides of the cut where your box was subtracted from your cylinder-cone from step 19.

In addition, make sure that “up” in the house is “up” on the sheet (one possible correct orientation is shown below). Your plot can have either portrait or landscape orientation, but make sure that your house is not tilted on the sheet.

Plot the view from model space. This sort of view is seldom used in working drawings, so you do not need to bother setting up a layout, title block, etc.
Within the “Plot” dialog box, either choose to plot “Extents”, or specify a window which shows your entire building as large as possible. Use “fit to paper” for the Plot Scale.

Select “monochrome.ctb” for the Plot style table.

**Important**: On the right-hand side of the dialog box, under “Shaded viewport options”, make sure that you select “Hidden” for the setting of “Shade Plot”. If you do not do this, hidden lines will not be removed in the plot, regardless of whether or not they are removed on the screen.

Check your plotted sheet to make sure that you have consistent and sensible lineweights in your plot. If some of your lines are overly thick, or if different lines in the plot have different lineweights, correct the lineweights and plot again.

Be sure to write your name on the finished plot.

22. **Use the DVIEW command to generate an interior perspective of your chosen room.** An interior perspective is a drawing that looks as if you were inside a room. It is *not* merely looking at the room interior from above or outside, but rather, looking from inside the room.

Start by using the PLAN command to return to a plan view of your building. Then type “DVIE” at a command prompt.

This command is old and somewhat arcane, but it allows you to specify perspective images in a precise manner. Producing an interior perspective is very difficult without the DVIEW command. Provide the input shown below:

```
Command: dview
Select objects or <use DVIEWBLOCK>: all
174 found
```
Select objects or <use DVIEWBLOCK>: <return>

The selected objects are what you will see while within the DVIEW command. They will not affect the view that ultimately results, but selecting all your drawing entities should make the command easier to use.

Enter option
[Camera/Target/Distance/Points/PAn/Zoom/TWist/CLip/Hide/Off/Undo]: po
Specify target point <26'-10", 16'-10", 4'-2 13/16">: .xy
of <click a target point in plan> (need Z): 5'

By indicating that you will specify Points, and specifying the target point as indicated above, you tell the DVIEW command where to aim the “camera.” Make sure that you choose a target point (and a camera point, as described below) that will put the 3D objects you have created in the image. Use 5’ for the Z-coordinate.

Specify camera point <26'-10", 16'-10", 4'-3 13/16">: .xy
of <click a target point in plan> (need Z): 5'

The camera point (called “eye point”, “look-from point”, or “station point” in other programs) indicates the point from which the model will be viewed.

By specifying Z-coordinates of 5’ for both the camera point and the target point, you have indicated the approximate eye level for a human; the perspective image will show a view that person might see if they are standing in the room, looking horizontally. Vertical lines in the image will not converge either upwards or downwards.

You should then use the “Distance” subcommand and accept the default distance:

Enter option
[Camera/Target/Distance/Points/PAn/Zoom/TWist/CLip/Hide/Off/Undo]: d
Specify new camera-target distance <16'-6 1/8">: <return>

You don’t actually want to change the distance between the camera and target point, but because of a bizarre behavior pattern in DVIEW, you need to use the Distance subcommand in order to get the “Zoom” subcommand to work well.

Next, use the following subcommand:

Enter option
CAmera/TArget/Distance/POints/PAn/Zoom/TWist/CLip/Hide/Off/Undo]: z
Specify lens length <50.000mm>: 20

“Lens length” is AutoCAD’s indirect way of having you specify what other programs call a “cone of vision,” “pyramid of vision,” or “angle of vision.” It says how much peripheral vision to include in the image. The greater the angle of vision included in the view, the greater the distortion will be at the corners. Larger angles of vision correspond to shorter camera lens lengths. 20mm (or maybe 15mm) is about the smallest lens length you can use (i.e., the widest angle lens you can use) before the distortion starts to become disorienting.

If you understand how the cone of vision and DVIEW lens length work, you can use a different value instead of 20, if you wish.

Enter option
[Camera/Target/Distance/Points/PAn/Zoom/TWist/CLip/Hide/Off/Undo]: d
Specify new camera-target distance <16'-6 1/8">: <return>
You need to use the Distance subcommand above merely to make your camera lens length take effect. You should not actually change the distance.

Enter option
[CAmera/TArget/Distance/P0ints/PAn/Zoom/TWist(CLip/Hide/Off/Undo]: <return>
Regenerating model.

This finally ends the command, and causes a perspective image to be displayed on the screen.

Unfortunately, if you make any mistakes within the DVIEW command, it is very difficult to fix them. The best thing to do is often to terminate the command (using the “Esc” key once or twice), then return to a PLAN view and start the command over again.

23. Plot the current view on the screen. Use “Extents” or “Display” for “What to plot”. Use “Fit to paper” for plot scale. Specify “monochrome.ctb”, and indicate “Hidden” for “Shaded viewport options”.

24. Repeat step 23, but don't remove the hidden lines. Indicate “Wireframe” for “Shaded viewport options”.

25. Plot any additional views that you feel are necessary in order to show your work. They should be monochrome, and you should use “Hidden” for the “Shaded viewport options”. Demonstrated control of the DVIEW command will also count as a small amount of embellishment/additional work.

Feel free to use pencil or pen to call attention things in the plots, or to explain commands used.

What's due:

A plot from model space, fit to paper, showing a parallel-line projection of your entire floor plan, with hidden lines removed (step 21).

A plot from model space, fit to paper, showing an interior perspective of your chosen room, with hidden lines removed (step 23).

A plot from model space, fit to paper, showing the same interior perspective of your chosen room, plotted wireframe (step 24).
Any other plots (but preferably less than 6) that you feel are necessary to show your embellishment and extra work, with hidden lines removed (step 25).